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ABSTRACT 
 

Materials are one of the important part of the construction industry. Materials contribute about 50-60% of the total 

cost of the project. As materials forms a major constitute of the total cost of the construction project, therefore 

adequate control over the purchasing, supplier selection, receiving, delivery, issuing storage, movement and its 

consumption is necessary. The most important among this is supplier selection and it leads to the success of and 

construction project. Supplier selection includes qualitative and quantitative factors. In this project, for the purpose 

of supplier selection in VVCMC (Vasai Virar City Municipal Corporation) region various data about the supplier 

like personal detail, location, quantity, quality, cost, delivery services, discount, transportation, communication 

facility, etc. are collected. Collection of these information would be less time consuming using database. This all 

data is imported in QGIS (Quantum GIS), since it is very effective tool for database management. By using QGIS 

software, digitise map of study area and roads is done. To locate the location of suppliers as per the requirements 

various queries are generated. It will also help in finding shortest route between supplier location and construction 

site. 
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1. INTRODUCTION  
 
This report covers Study region, Data collection and Data analysis of construction material suppliers present in 

Vasai-Virar Municipal Corporation. The Vasai-Virar City Municipal Corporation, (VVCMC) is the civic body that 

governs areas and villages in Vasai-Virar tehsil in Maharashtra state, western India comprising the most populated 

part of Palghar district. It is an extended suburb of Mumbai. According to the 2011 census, it is the fifth largest city 

in Maharashtra with a population of more than 1.3 million. The city is located 50 km north of Mumbai, on the north 

bank of Vasai Creek, part of the estuary of the Ulhas River. It was formed on 3 July 2009 by combining four 

municipal councils and 53 gram panchayats. Vasai-Virar City is the only Metropolitan City (having population more 

than 10 lakhs in Palghar district which is also having Municipal Corporation. It is located at North Mumbai. The area 

of Vasai-Virar City is 311 sq. km. Vasai-Virar City has been separated from Greater Mumbai and Mira-Bhayandar 

City because of presence of Vasai Creek. The City is well connected to Mumbai by Western Railway and through 

Mumbai-Ahmedabad National Highway. The city is connected to Navi Mumbai, Thane, Bhiwandi, Kalyan and 

Panvel cities by the Vasai-Diva Railway line. Vasai Virar city has significant growth potential due to close proximity 

to Brihan Mumbai. The Vasai-Virar City Municipal Corporation (VVCMC) was established on 3rd July 2009. Vasai 

Virar Corporation is located between 19 deg. 28 min. north-90 deg. 47 min. north latitude and 72 deg. 48 min. east-

72 deg. 8 min. east. The VVMC is responsible for aiding in prevention of epidemic outbreaks through mass 

production of medicines, Cemeteries and Crematoria, Fire Stations, Garbage disposal and street cleanliness, House 

Tax, Lighthouses, Maintenance of parks and open spaces, Markets, shops, and establishments, Municipal water, 

Public health and hospitals, Registering of births and deaths, Removal of encroachments, Security, Sewage treatment 

and disposal, Street lighting, Transport and Construction of Roads. 

 

https://en.wikipedia.org/wiki/Vasai-Virar
https://en.wikipedia.org/wiki/Maharashtra
https://en.wikipedia.org/wiki/India
https://en.wikipedia.org/wiki/Palghar_district
https://en.wikipedia.org/wiki/Vasai_Creek
https://en.wikipedia.org/wiki/Ulhas_River
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2. LITERATURE REVIEW  
 

Materials Management 
Materials management is a process for planning, executing and controlling field and office activities in construction. 

The goal of materials management is to ensure that construction materials are available at their point of use when 

needed. The materials management system attempts to ensure that the right quality and quantity of materials are 

appropriately selected, purchased, delivered and handled on site in a timely manner and at a reasonable cost. 

Materials management is the system for planning and controlling all of the efforts necessary to ensure that the 

correct quality and quantity of materials are properly specified in a timely manner, are obtained at a reasonable cost 

and most importantly are available at the point of use when required. Thus, Materials management is an important 

element in project management. Materials represent a major expense in construction, so minimizing procurement 

costs improves opportunities for reducing the overall project costs. 

 

Purchasing procedure  
Step 1 – Material Indent 

Step 2 – Enquiry to Suppliers/Vendors  

Step 3 – Vendor Comparison  

Step 4 – Vendor Selection and Negotiations  

Step 5 – Purchase Order  

Step 6 – Suppliers/Vendor Evaluation 

 
Receiving of materials 
The receipt system can be divided into: 

a) Receipt from outside suppliers 

b) Receipts from internal divisions. 

System of receipt starts even before the material reaches the site. The three documents that should be dispatched are 

copy of purchase order, supplier’s advice document and the consignment note. This enables the Stores manager to 

organize and plan for clearances of materials. For receipt from internal divisions, usually transfer notes and return to 

stores documents are used. 

 

Inspection of materials 
a) Pre-dispatch inspection 

b) Inspection on site 

It is the responsibility of the inspector to inspect all materials delivered to the site prior to their being used in the 

work. It is desirable to perform inspection of materials or fabricated products prior to their delivery at site. The 

inspector shall have rights to reject faulty material and have it removed from site. With respect to manufactured 

goods, the quality requirements should be specified in the purchase order. 

 

Stacking and Storage of materials 
The physical storage system on site vary according to the space availability and company practices. Industrial 

guidelines are also taken into consideration for the stacking and storage of particular materials. The materials are 

also often stacked as per the specification of the vendor or manufacturer. 
a) The materials should not be affected by impurities or atmospheric agencies. 

b) Materials like cement should must be stored in covered sheds and stacked on timber raised platforms. 

c) Reinforcing bars should be stacked yards away from moisture to prevent rusting and also away from oil and 

lubricants. Bars of different classification, sizes and lengths should be stored separately to facilitate issues. 

 

Issuing materials 
a) Issues to consuming departments 

b) Issues to outside suppliers for processing or conversion. 

Issuing on site does not happen in the case of all construction materials. In the case of sand or aggregate, the 

materials are consumed as and when required corresponding to the progress of the project. For other materials, 

issues are based on production programs. Based on this and the bill of materials, work orders are printed, listing for 

each material, quantity to be issued against each component requiring that material. This automatically controls 

consumption. 
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Critical success factors for supplier selection 

a) Quality of materials 

b) Quantity of materials 

c) Price of materials 
d) Availability of materials 

e) Delivery service  

f) Technical capability  

g) Financial strength 

h) Geographical Location 

i) Reputation 

j) Management and Organisation 

k) Other factors. 

Major steps of supplier selection  
Step 1 - Identification of the need for a specific product  

Step 2 - Identify key sourcing requirements and criteria  

Step 3 - Determine sourcing strategy  

Step 4 - Identify potential supply sources  

Step 5 - Limit suppliers in selection pool  

Step 6 - Determine method for final selection  

Step 7 - Select suppliers and reach agreement. 

 

Geographical Information System (GIS) 
A Geographic information system is a computer based system capable of capturing, storing, and analysing and 

displaying geographically referenced information; that identified according to location. Practitioners also define a 

GIS as including the procedures, operating personal and spatial data that goes into system. A GIS tool is used for 

mapping and analysing spatial data. GIS technology integrates common database operations such as query and 

statistical analysis with the unique visualization and geographic analysis benefits offered by maps.  

 

Working of GIS 
GIS stores information about the world as a collection of thematic layers that can be linked together by geography. 

This simple but extremely powerful and versatile concept has proven invaluable for solving many real world 

problems from modelling global atmospheric circulation, to predicting rural land use, and monitoring changes in 

rainforest ecosystems. 1. Geographic references 2. Input of data 3. Map making 4. Manipulation of data 5. File 

management 6. Query and Analysis 7. Visualization. 

 

 

 

3. CASE STUDY 
 

3.1 Study Region 
 

The Vasai-Virar City Municipal Corporation, (VVCMC) is the civic body that governs areas and villages in Vasai-

Virar tehsil in Maharashtra state, western India comprising the most populated part of Palghar district. It is an 

extended suburb of Mumbai. According to the 2011 census, it is the fifth largest city in Maharashtra with a 

population of more than 1.3 million. It was formed on 3 July 2009 by combining four municipal councils and 

53 gram panchayats.Vasai-Virar City is the only Metropolitan City (having population more than 10 lakhs in Palghar 

district which is also having Municipal Corporation. It is located at North Mumbai. The area of Vasai-Virar City is 

311 sq. km.Vasai-Virar City has been separated from Greater Mumbai and Mira-Bhayandar City because of presence 

of Vasai Creek. The City is well connected to Mumbai by Western Railway and through Mumbai-Ahmedabad 

National Highway. The city is connected to Navi Mumbai, Thane, Bhiwandi, Kalyan and Panvel cities by the Vasai-

Diva Railway line.Vasai Virar city has significant growth potential due to close proximity to Brihan Mumbai. Vasai 

Virar Corporation is located between 19 deg. 28 min. North-90 deg. 47 min. North latitude and 72 deg. 48 min. East-

72 deg. 8 min. East. 

 

 

https://en.wikipedia.org/wiki/Vasai-Virar
https://en.wikipedia.org/wiki/Vasai-Virar
https://en.wikipedia.org/wiki/Maharashtra
https://en.wikipedia.org/wiki/India
https://en.wikipedia.org/wiki/Palghar_district
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3.2 Data acquisition 
Approximately, Total 68 major construction materials suppliers are available in Vasai Virar City Municipal 

Corporation region. Most popular and mostly available suppliers are present in Nallasopara and Vasai highway area, 

virar east etc. The scope of materials was restricted to only sand, crushed sand, cement, aggregate, brick, steel and 

concrete owing to its importance and availability. Moreover, six materials were chosen to prepare the GIS model 

since the same methodology can be applied to other materials also subsequently. Collection of data included personal 

information of suppliers like name and address, details of materials like cost, brand, quarry source, available stock, 

lead time, discount, transportation, guarantee for safety, replacement, test certificates, etc. It could be observed that 

the cost of materials varied among the suppliers. The Vasai Virar City Municipal Corporation map was obtained 

from Vasai Virar Municipal Corporation (VVCMC) office Virar. The map comprised of basic data like latitude-

longitude, boundary area, roads, railway lines, and river, apart from depicting the legend. The scale of map is 

1:10000, ideal to enable digitisation using QGIS software. In my project most required boundary of Vasai Virar City 

Municipal Corporation, Roads, supplier’s data and supplier’s location in Vasai Virar City Municipal Corporation. 

The data required for digitisation of the Vasai Virar map and the attribute data required for building the data base 

were collected through a data collection sheet. Simultaneously, GPS was used on site to record the Latitude-

Longitude details of the locations of various suppliers. 

 

 

 

4. MEHODOLOGY AND APPLICATION OF GIS MODEL 

 
This chapter will give information about suppliers present in Vasai Virar City Municipal Corporation and related 

their data with QGIS software. It also shows the queries run in various modules. Vector analysis are used to run 

different query are described. This chapter gives the procedure of data base generation, showing different queries run 

in QGIS and its need and application. 

 

4.1 Preparation of data base 

 
The database is prepared using Microsoft Excel. 

Inserting field name in Column of Excel Sheet as follows  

Name of shop, Cost of sand, Cost of Crushed sand, Cost of cement, Cost of steel, Cost of brick, Cost of Concrete, 

lead time, address, mobile number, Longitude , Latitude etc. and fill available data of all suppliers in particular 

column. 

Digitisation of supplier’s locations of Vasai-Virar City Municipal Corporation in point layer is done using database. 

 

4.2 Procedure for database generation 

 
Step 1: Open QGIS icon→ Web→ Google Maps → Google Streets 

             Google Street Map is opened. 

Step 2: Digitisation of supplier’s locations of Vasai Virar City Municipal Corporation in point layer. 

            Open layer → Add Layer → Add Delimited Text Layer 

  Step 3: Click on Browse→ Select this file from computer “Data of Vasai-Virar Shops” →Select File format as                            

CSV→Select Geometry Definition as Point Co-ordinates→Select X Field as LONGITUDE and Y Field as 

LATITUDE →Click on OK 

Step 4: Select Co-ordinate Reference System as EPSG-4326 → Click OK 

Step 5: Select Data of Vasai Virar shop → Right click → Select Zoom to Layer 

Step 6: Digitilization of Roads 

             Select Plugins → InaSAFE →OpenStreetMap Downloader 

Step 7: Select Roads →Select Drag on Map → Select VVCMC Region 

By following the above Steps the data base is generated. 
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Fig-1: Digitised map shows table creation of supplier location layer of supplier’s data 

 

 
Fig-2: Digitised map shows road network in Vasai-Virar City Municipal Corporation. 

 

 

 

5. QUERIES IN QGIS 

 
In analysis, map of Vasai Virar City Municipal Corporation is opened with all layer and database of suppliers like 

available materials, cost,lead time,transportation facility etc are created . This is shown in following image. This data 
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helps to create queries. And it will help to give output of every perticular query. That information helps to supplier 

selection process. 

 
Fig 3: Image shows analysis of Vasai-Virar City Municipal Corporation map with all layers and database created in QGIS 

 

 

5.1 GENERATION OF QUERIES 

 

Query No.1: Find out cost of ACC cement equal to Rs. 330 per bag. 

 
If supplier selection manager wants to know the number of supplier’s having cost of ACC Cement equal to Rs. 330 per 

bag in Vasai Virar then he easily gets the related information within minutes just by running the query in GIS vector 

analysis. 

 

Procedure: 

 Open QGIS → Vasai Virar project 

 Click on layer → Data of Vasai Virar shop →Select filter 

 Then enter the condition of query i.e. Cost ACC Cement = “330”. 

 Then click on OK button to get result of query. 

 

Result of Query 1: 

The result shows that 6 out of 68 supplier’s having cost of ACC Cement equals to Rs. 330 per bag. 

 

Utility of Query: 

 It gives better information of all suppliers present in Vasai Virar City Municipal Corporation who having cost of 

ACC cement is Rs. 330 per bag. 

 It helps to find maximum suppliers along with location and easily compare each other. 

 After comparing it helps to select nearest best suppliers for purchasing ACC cement of Rs. 330 per bag. 
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Fig-4: Image shows the result of Query No 1. 

 
Query No.2: Find out cost of sand is less than Rs. 6000 per brass and lead time is less than or equal to 18 

hrs and quarry source is vaitarna with discount. 

 
If supplier selection manager wants to know the number of supplier’s having cost of sand less than Rs. 6000 per brass, 

lead time is less than or equal to 18 hrs, quarry source is vaitarna with discount. Then he easily gets the related 

information within minutes just by running the query in GIS vector analysis. 

 

Procedure: 

 Open QGIS → Vasai Virar project 

 Click on layer → Data of Vasai Virar shop  

 Then enter the condition of query i.e. Cost Sand per brass < “6000” AND “Lead Time” <= 18 AND “Quarry 

source” = vaitarna and “Discount” = Yes. 

 Then click on OK button to get result of query. 

 

Result of Query 2: 

              The result of this query is 10 out of 68 suppliers are eligible for this condition. 

 

Utility of Query: 

 Supplier selection manager collect multiple data together by using this query. 

 This information helps to give the scale points to suppliers in supplier selection process in one click. 

 It will help to reduce the time for supplier selection process. 

 And hence supplier selection manager selects ideal supplier in very short time by using no. of condition. 
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Fig-5: Image shows the result of Query No 1. 

 
Query No.3: Find shortest route between construction sites and supplier’s location 
Construction manager or supplier selection manager wanted to know the shortest distance between construction site and 

supplier’s location in Vasai Virar City Municipal Corporation then he easily gets the solution by using network analysis. 

 

Procedure: 

 Open QGIS → Vasai Virar project 

 Click on layer → Data of Vasai Virar shop  

 Select Vector →Road Graph →Setting 

 Enter relevant Data in Road Graph Plugin Setting 

 Enter speed by which transportation vehicle will move. 

 Select Source and Destination Location From the map and click on calculate 

 

Result of Query No.3 

This query shows the shortest path Between Source and Destination. It also shows Length(in km) of the path and 

time(in hours) required to complete the journey. 

 

Utility of Query 

 It gives the information of shortest route between construction site and supplier’s location. 

 Shortest route will help to save the time and reduce the cost of transportation. 

 It helps to deliver materials in timely on construction sites. 

 It helps to gives path information, path nodes, details of ‘from node’ and ‘to node’, and distance of each nodes. 

 It helps to calculate distance between source and destination.  
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Fig-6: Image shows shortest route in red colour between source and destination. 

 

 

6. CONCLUSION 
 Excellent performance of material suppliers is most essential for the smooth obtaining of materials. 

Supplier evaluation and selection is a usual main issue. The multi-criteria signify both qualitative and 

quantitative characteristics. Construction contractor should be able to select the appropriate decision-

making tool which is easy, reliable and affordable. 

 It is essential to have an applicable structured decision-making system in today’s complex construction 

industry. This particularly helps quality decisions and consistency and transparency under complex multi-

criteria conditions. The rationale for this research being predicated on the need model the construction 

material supply behaviour to optimise the material purchasing decisions. In practice, supplier selection is 

based on perceived importance of selection criteria. 

 The nature of the multi-criteria decision method influences on each criterion (e.g. quality, delivery 

dependability, price, etc.). Therefore, there a possibility for examination of the effect of interdependencies 

among the criteria towards the decision making process of supplier selection in the construction industry. 

 Here GIS tool is very effectively to avoiding problems in very short time which are creating for supplier 

selection. And which is very helpful for integrate and categorised of supplier’s data so any time ideal 

supplier selection is very easy. 

 Approximately 130 major construction materials suppliers are available in Vasai-Virar City Municipal 

Corporation region. So, it is very time-consuming process to collect required data for supplier selection 

process from all suppliers present in Vasai-Virar City Municipal Corporation. 

 GIS gives information of all data of suppliers like location of suppliers, available materials, cost of 

materials, quantity, lead time, stock, discount etc. 

 Multiple condition of suppliers in GIS queries can be used and it will helps to give the scale points to 

suppliers in supplier selection process in one click. So reduce the time for supplier selection process and 

hence supplier selection manager select ideal supplier in very short time. 

 GIS queries play an important role when non-availability and emergency requirement of materials. 

 GIS network gives the information of shortest route between supplier’s location and construction site with 

distance in very short time. 

 GIS network gives the information of another shortest route if route of construction site is not free. It also 

helps to find out nearest supplier. 
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